Reviews & Opinions
Independent and trusted. Read before buy Adobe Atmosphere Builder 1!

Adobe Atmosphere Builder 1

Manual

Preview of first few manual pages (at low quality). Check before download. Click to enlarge.
Manual - 1 page  Manual - 2 page  Manual - 3 page 

Download (English)
Adobe Atmosphere Builder 1, size: 2.0 MB
Instruction: After click Download and complete offer, you will get access to list of direct links to websites where you can download this manual.

About

Adobe Atmosphere Builder 1About Adobe Atmosphere Builder 1
Here you can find all about Adobe Atmosphere Builder 1 like manual and other informations. For example: review.

Adobe Atmosphere Builder 1 manual (user guide) is ready to download for free.

On the bottom of page users can write a review. If you own a Adobe Atmosphere Builder 1 please write about it to help other people.

 

[ Report abuse or wrong photo | Share your Adobe Atmosphere Builder 1 photo ]

User reviews and opinions

<== Click here to post a new opinion, comment, review, etc.

Comments to date: 4. Page 1 of 1. Average Rating:
DrDomino 12:30pm on Tuesday, October 26th, 2010 
My Company uses Citrix, so I am able to run Windows Applications, SAP, even flash and all my GO TO corporate applications on the device. Does this device have any real flaws? Lets address some real shortcomings of the iPad.
Metzen 12:50am on Thursday, June 17th, 2010 
The iPad is exactly what I expected, easy to use, very well executed so long as you understand that it is mainly a device to consume media.
signs 9:54pm on Wednesday, April 28th, 2010 
I replaced my first-gen iPod Touch, which I had since they first came out a few years ago, with this new beast of a device. First of all.
mjplaine 3:23pm on Friday, April 2nd, 2010 
Bought the 16G WiFi for my wife. She enjoys playing games, surfing the web, reading books, reading email and catching up on her Soaps at ABC.com.

Comments posted on www.ps2netdrivers.net are solely the views and opinions of the people posting them and do not necessarily reflect the views or opinions of us.

 

Documents

doc0

Adobe Atmosphere

Frequently Asked Questions
The next generation software for the Web that lets users create graphically rich, dynamic, 3D worlds and interact with others in realtime
What is Adobe Atmosphere? Adobe Atmosphere is a professional development solution for creating virtual 3D environments for the Web. Adobe Atmosphere includes three components: Atmosphere Builder, a powerful application for authoring 3D worlds for the Web. Atmosphere Player, a free downloadable plug-in for Web browsers, or a standalone player, that enable anyone to explore 3D worlds created in Adobe Atmosphere and to interact with those worlds and the other people visiting them. Atmosphere Community Server, a messaging server that enables chat and interaction in 3D worlds created in Atmosphere. When will Adobe Atmosphere be available? In order to build on the growing momentum for Adobe Atmosphere, Adobe has decided to keep Atmosphere in public beta through the end of the year to focus development efforts on increasing product functionality and enhancing the developer and user experience. While we currently do not have a specific time frame to communicate, Adobe plans to release the final product upon termination of the public beta period. Is Atmosphere available for the Mac? We do not currently have a timeframe for when the Macintosh version will be available. How much will Atmosphere cost? The suggested retail price for the Atmosphere Builder will be announced when the final product ships. Is a plug-in required for viewing content built with Atmosphere? Yes, content built with Atmosphere requires a plug-in to view. The Atmosphere Player is a free plugin that will automatically download and install on demand when a web page containing an Atmosphere world is encountered. It is approximately 1.4 megabytes in size, and currently requires a Windows system running Microsoft Internet Explorer 5 and above. Will I have to buy a server or will users have to pay to use Atmosphere worlds? No, the source code for the Atmosphere Community Server is available at no cost under a simple license from Adobe. Adobe has no plans to restrict the use of the Atmosphere Community Server. Do I need to run a server to make my Atmosphere world multi-user? During the public beta period, Adobe is providing users of the Atmosphere Builder access to a community server that will allow for the creation of worlds that are automatically community-enabled. Do I need special hardware to create or view 3D worlds with Atmosphere? No. Atmosphere will currently run on any standard personal computer running modern versions of the Microsoft Windows operating system. However, it is intended that future public betas and the final release of Atmosphere will take advantage of accelerated 3D video cards. Who is the targeted user of the Adobe Atmosphere Builder? The Adobe Atmosphere Builder is targeted at professional 3D content creators and Web designers. However, because of its intuitive user interface and rich feature set, it is easily used by anyone who wants to design interactive 3D environments on the Web.
Who is the targeted user of the Adobe Atmosphere Player? The Adobe Atmosphere Player is targeted at anyone who wants to explore the Web and interact with others in a 3D virtual world environment, particularly in the areas of e-retail, education, exploration, entertainment, and communication. What file formats does Atmosphere support? You can import most Web graphics formats into an Atmosphere world, including JPEG, GIF, PNG, WAV, and MP3. In addition, for world and avatar designers, Atmosphere provides support for 3D objects created in any 3D design tool that includes a Viewpoint file format export optionincluding Curious Labs Poser, Curious Labs Avatar Lab, Caligaris TrueSpace for Atmosphere, Discreet 3D StudioMax, Alias/Wavefront Maya, and Newtek Lightwave. Does Atmosphere support animation and interaction? Yes. Atmosphere supports animated objects in two ways. Animated objects created in any 3D creation tool and exported as a Viewpoint file may be imported into Atmosphere, complete with animations. In addition, you can use JavaScript to animate objects and implement interactivity in your worlds. Does Atmosphere support sound? Yes. Atmosphere supports the WAV and MP3 file formats. Will Atmosphere support multi-user synchronized game play and interaction? Yes, it is intended that future versions of Atmosphere will support these capabilities, using a simple JavaScript API. Will Atmosphere support streaming media playback and in-scene Web pages? Yes, it is intended that future versions of Atmosphere will support these capabilities, using a simple JavaScript API and standard multimedia formats. How do I enable chatting and support multiple visitors in an Atmosphere world? When you publish a 3D virtual world with Atmosphere, you can post your world files on any HTTP server available to you. To enable chatting and to support multiple users, you will need to designate a community server. Adobe provides a URL so that Adobe Atmosphere Builder users can create worlds that are community enabled. Thus, is it not necessary to run a Community Server of your own in order to publish an interactive, multi-user world. Will the final shipping version of Atmosphere include additional features not available in the current public beta? Adobe is actively working on new features for Atmosphere throughout the public beta period. From time to time, these features may be released in public betas, and are intended to appear in the released version of Atmosphere. In addition to the features mentioned above, which include support for 3D accelerator hardware, synchronized game play and interaction, and streaming media, work is also being done to support realtime physical-based animation for intuitive character motion and rich interactive simulations. Is the Canoma product and/or the Carrara technology licensed from MetaCreations part of Adobe Atmosphere? No. Canoma and Carrara are not currently incorporated into Atmosphere; however, Adobe is committed to enabling the creation and viewing of 3D worlds. Adobe acquired the Canoma product line and licensed the Carrara technology from Viewpoint (formerly MetaCreations) in Fall 2000. Viewpoint retained responsibility for supporting the Canoma product. Adobe may apply portions of Canoma and/or Carrara into future versions of its graphics and web products. How can I participate in the current public beta of Atmosphere? You can download the current public beta, and a variety of support documents and examples, from www.adobe.com/products/atmosphere. With the downloaded files, you can explore and interact in Atmosphere worlds posted by others, or build and post worlds of your own.

Adobe Systems Incorporated 345 Park Avenue San Jose, CA 95110-2704 USA World Wide Web www.adobe.com This document was created with Adobe PageMaker software and font software from the Adobe Type Library. 2002 Adobe Systems Incorporated. All rights reserved. Adobe and AlterCast are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries. All other trademarks are the property of their respective owners.

doc1

atmosphere.book Page 1 Wednesday, March 21, 2001 6:14 PM

Online Help

version

Adobe Atmosphere 1.0

atmosphere.book Page 2 Wednesday, March 21, 2001 6:14 PM
2001 Adobe Systems Incorporated. All rights reserved. Adobe Atmosphere Builder This manual, as well as the software described in it, is furnished under license and may be used or copied only in accordance with the terms of such license. The content of this manual is furnished for informational use only, is subject to change without notice, and should not be construed as a commitment by Adobe Systems Incorporated. Adobe Systems Incorporated assumes no responsibility or liability for any errors or inaccuracies that may appear in this book. Except as permitted by such license, no part of this publication may be reproduced, stored in a retrieval system, or transmitted, in any form or by any means, electronic, mechanical, recording, or otherwise, without the prior written permission of Adobe Systems Incorporated. Please remember that existing artwork or images that you may want to include in your project may be protected under copyright law. The unauthorized incorporation of such material into your new work could be a violation of the rights of the copyright owner. Please be sure to obtain any permission required from the copyright owner. Any references to company names in sample templates are for demonstration purposes only and are not intended to refer to any actual organization. Adobe and the Adobe logo are trademarks of Adobe Systems Incorporated. Microsoft and Windows are registered trademarks of Microsoft Corporation in the U.S and/or other countries. All other trademarks are the property of their respective owners. Notice to U.S. government end users. The software and documentation are commercial items, as that term is dened at 48 C.F.R. 2.101, consisting of commercial computer software and commercial computer software documentation, as such terms are used in 48 C.F.R. 12.212 or 48 C.F.R. 227.7202, as applicable. Consistent with 48 C.F.R. 12.212 or 48 C.F.R. 227.7202-1 through 227.7202-4, as applicable, the commercial computer software and commercial computer software documentation are being licensed to U.S. government end users (A) only as commercial items and (B) with only those rights as are granted to all other end users pursuant to the terms and conditions set forth in the Adobe standard commercial agreement for this software. Unpublished rights reserved under the copyright laws of the United States.
atmosphere.book Page iii Wednesday, March 21, 2001 6:14 PM

Contents

Atmosphere Builder Basics
About Atmosphere Builder Creating and opening worlds Working with views Navigating in wireframe views Navigating in Browser view Using the Actor object Using palettes.. 1.. 1. 3. 2.. 5

.. 6. 8

.. 7. 9. 11. 13. 15. 16
Saving and publishing worlds Closing and quitting

Building Worlds

About building worlds
Adding objects to a world
Specifying where to add objects Using the Object Inspector palette Creating oors Creating walls Creating boxes Creating stairs
. 17. 18. 19. 21. 21. 23. 25. 27
Creating slabs and trislabs Creating cones and columns Combining objects
Exporting and publishing objects

Working with Objects

About working with objects Using the Objects palette Selecting objects Moving objects Deleting objects Duplicating objects Grouping objects

atmosphere.book Page 4 Wednesday, March 21, 2001 6:14 PM
Scrolling wireframe views
If the area of the wireframe you want to work on is not visible in the document window, you can scroll to bring that area into view.

To scroll a view:

Select the pan tool (
), and drag in the document window.

Rotating wireframe views

You can rotate a wireframe view in the document window to see the objects from a different perspective. Keep in mind that rotating the view does not change the orientation of individual objects, only the angle at which you see the wireframe as whole. For information on rotating individual objects, see Rotating objects on page 40.

To rotate a view:

1 Select the rotate objects tool (
2 Drag to the left in the document window to rotate the view clockwise; drag to the right to rotate the view counter-clockwise.
Magnifying and reducing wireframe views
You can magnify your view to see the wireframe in greater detail, or you can reduce your view to see a larger portion of the wireframe. Keep in mind that zooming in and out does not change the actual size of the objects, only the magnication at which you see them. For information on changing the scale of objects, see Scaling and distorting objects on page 41.
To zoom in and out by dragging:

1 Select the zoom tool (

2 Drag to the right in the document window to zoom in, or to the left to zoom out. Your
view zooms in and out on a continuous range of percentages based on how much you drag.

To zoom in by clicking:

Select the zoom in tool ( to magnify.
), and click a point in the wireframe around which you want
atmosphere.book Page 5 Wednesday, March 21, 2001 6:14 PM

ADOBE ATMOSPHERE 5

To zoom out by clicking:
Select the zoom out tool ( to reduce magnication.
Centering wireframes in the document window
After navigating in the wireframe views, you can quickly display all of the objects in the wireframe and center the view in the document window.
To center a wireframe in the document window:
Choose View > Fit All.
Navigating in Browser view
Browser view presents a shaded, perspective view of a world. You can navigate around this world using your mouse and keyboard commands. You can move forward and backward through doorways, climb up and down stairs, and look side to side. You can also set options that determine the quality of your movement.

Moving the Actor object in a wireframe view changes your position in Browser view. To change your position and orientation in Browser view using the Actor object:
1 Select a wireframe view: Top, Side, or Isometric. 2 Select the Actor object (
). (See Selecting objects on page 30.)
3 Drag the Actor object to the desired position in the wireframe.
atmosphere.book Page 7 Wednesday, March 21, 2001 6:14 PM

ADOBE ATMOSPHERE 7

4 If necessary, rotate the Actor object until it is pointing in the direction you want to face
in Browser view. (See Rotating objects on page 40.)
5 Switch to Browser view.

Using palettes

Atmosphere Builder features a variety of palettes that you use to perform different tasks, including selecting tools and views, adding objects to a world, and setting the properties of those objects. When you rst start Atmosphere Builder, several palettes are displayed by default. You can choose to show and hide palettes as you work. A group is a window that lets you organize palettes. You can move all palettes into a single group or move each palette into its own group window. You can also close and resize groups to make better use of your work area.
To show a palette and any palettes in its group:
Choose the palettes name in the Window menu.
To hide a palette and any palettes in its group:
Click the close box in the upper right corner of the group window.
To bring a palette to the front of its group:
Click the palettes tab, or choose the palettes name in the Window menu. A check mark next to the palettes name in the Window menu indicates that the palette is visible and at the front of its group.
To move a palette between groups:
Drag the palettes tab to another group.
To move a palette so that it appears in its own window:
Drag the palettes tab to the desktop.
To move a group of palettes:
Drag the groups title bar.
atmosphere.book Page 8 Wednesday, March 21, 2001 6:14 PM
To resize a group window:
Drag the lower right corner of the window.
To collapse a group of palettes to a tab at the right edge of the screen:
Ctrl-click the title bar of the group window. To expand the group window, click the tab at the right edge of the screen.

Closing and quitting

When youre done working in Atmosphere Builder, you can close the current world le and exit the application.

To close a world le:

Choose File > Close
To quit Atmosphere Builder:
Choose File > Exit. If you did not save the le before choosing the Exit command, the Save dialog box appears. Enter a name for the le (if necessary), and click Save.
atmosphere.book Page 10 Wednesday, March 21, 2001 6:14 PM
atmosphere.book Page 11 Wednesday, March 21, 2001 6:14 PM
There are two main aspects to building the structure of a world. The rst is creating objects; the second is laying out objects in relation to each other.

Creating objects

Objects are the building blocks of a three-dimensional worldyou use objects to dene space and give form to your vision. Atmosphere Builder provides tools for creating basic geometric forms called primitives. Primitivessuch as boxes, oors, polygons, walls, slabs, stairs, columns, and coneslet you quickly lay out the framework of a world. When you build with structure in Atmosphere Builder, you are working with the principles of constructive solid geometry. Because primitives are solid objects, they are easy to combine and form a solid structure. (You dont have to worry about wrapping polygons around a structure as you do in some 3D applications.) You can use primitives to create more complex objects by adding them together or subtracting them one from the another. Take, for example, a box object and wall object that intersect each other. By selecting the Connect Objects option in the Tool Inspector palette, Atmosphere Builder combines the objects to create a solid that represents a wall with a protruding box. However, you can choose to subtract the volume of the box from that of the wall, in which case you create a solid that represents a wall with a hole in it. You can also choose to intersect the volumes of the box and the wall, in which case you create a solid that has the depth of the wall and the height and width of the box.
atmosphere.book Page 12 Wednesday, March 21, 2001 6:14 PM
Although you can create an innite variety of objects using constructive solid geometry, there are some objects that you cannot create in Atmosphere Builder. Organic shapes, such as the human form, and spheres may only be approximated using the available primitives. This is where 3D objects saved in the Viewpoint le format come into play. Importing Viewpoint objects provides a way to add additional detail to a world. For example, you can create a model of a sh in another 3D modeling application and import it into Atmosphere Builder as a Viewpoint object.

F G C H

A. Box object B. Floor object C. Cone object D. Wall object E. Stairs object F. Column object G. Slab object H. Viewpoint object

Laying out objects

When building a world, the space between objects is as important as the objects themselves. For example, if you build a room using two oor objects and four wall objects, the amount of the space inside the room is dened by the relationship between objects. You can create a tall, narrow space by creating a narrow oor and tall walls, or you can create an expansive space by creating a wide oor and short walls.
atmosphere.book Page 13 Wednesday, March 21, 2001 6:14 PM

ADOBE ATMOSPHERE 13

As you add objects to a world, the relationship between objects becomes more complex. For example, if you want to increase the length of a room, all of the rooms components (the oor, walls, and ceiling) must change. Connectors let you link objects to each other and maintain their spatial relationships. Think of connectors as the bolts of your world. When objects are linked, you can move one connector to adjust an entire structure. Atmosphere manages the connections between objects in a world using constraints. Constraints determine how an object can be moved. For example, when you move a wall object that is connected to a oor object, Atmosphere Builder constrains the movement so that the wall remains vertical, the oor remains horizontal, and the wall and oor remain connected. This system of constraints adds stability to your world.
You can add objects to a world using the object tools that appear in the Variable Tools palette.

Creating new objects

The Variable Tools palette contains specialized tools for creating boxes, walls, oors, cones, columns, and stairs, as well as portals and entry points that let users travel between worlds.

To create a new object:

1 Select a wireframe view: Top, Side, or Isometric. 2 Select a tool in the Variable Tools palette. 3 If desired, set object properties in the Object Inspector palette. (See Using the Object Inspector palette on page 16.) 4 Do one of the following: Click in the document window to place the object. Hold the mouse button in the down position and drag in the document window to position the object. Note that dragging does not allow you to resize the object; it simply allows you to reposition the object.
After creating an object, you can change its properties in the Object Inspector palette.
atmosphere.book Page 14 Wednesday, March 21, 2001 6:14 PM

atmosphere.book Page 17 Wednesday, March 21, 2001 6:14 PM

ADOBE ATMOSPHERE 17

Creating oors
A oor object is any at, horizontal surface in an Atmosphere world. In the real world, we dene a oor as something we walk on; in Atmosphere, you can also use a oor object as a ceiling or as any other at horizontal surface such as a patio or deck. The oor tool lets you create a oor object that is initially square; however, you can adjust the length of each side by dragging the oors connectors. Floor objects always remain horizontal in a world, no matter how you adjust their connectors. For example, if youre working in Side view and move one of the oors connectors up, the whole oor (and any oor sections connected to it) moves up to keep the oor horizontal.

To add a oor object:

1 Select the oor tool (
) in the Variable Tools palette.
2 If desired, set one or more options in the Object Inspector palette: Object Name to enter a name for the object that will appear in the Object Inspector palette and the Objects palette. JavaScript URL to attach a script to the object. (See Attaching a script to a world on page 61.) Visible in Wireframe Views to show the object after you create it. (See Showing and
hiding objects on page 38.)
Hide in Browser View to create a hidden object, such as a hidden luminous object. (See Creating hidden luminous objects on page 54.) Locked to lock the object. (See Locking objects on page 37.) Subtractive to use the object to cut through another object. (See Creating openings in

objects on page 26.)

Thickness to specify the thickness of the horizontal surface in feet. 3 Click in the document window. If youre working in Top view or Isometric view, click where you want to locate the center of the oor. If youre working in Side view, click where you want to locate the midpoint of the oor thickness. Hold down the mouse button and drag to reposition the object.
atmosphere.book Page 18 Wednesday, March 21, 2001 6:14 PM

If the slab is connected to another object, such as a wall, drag that object up or down.
Note: Depending on the position of its connectors, a slab can become non-planar. (A nonplanar slab is one in which no single plane can be positioned through all of its connectors.) In this case, Atmosphere automatically breaks the slab into two triangular slabs. If the slab becomes planar again, the break is automatically removed and a single planar slab is restored.
atmosphere.book Page 21 Wednesday, March 21, 2001 6:14 PM

ADOBE ATMOSPHERE 21

Creating boxes
A box is an object that has six faces: a bottom, four sides, and a top. You can use box objects to represent solid objects such as cabinets, refrigerators, or other appliances. The box tool lets you create an object that is a cube with six equal sides. After you add a box, you can change its sides to be unequal lengths by dragging the boxs connectors.

To add a box:

1 Select the box tool (
2 If desired, set one or more options in the Object Inspector palette: Object Name to enter a name for the object that will appear in the Object Inspector palette and the Objects palette. JavaScript URL to attach a script to the object. (See Attaching a script to a world on page 61.) Visible in Wireframe Views to show the object after you create it. (See Showing and hiding objects on page 38.) Hide in Browser View to create a hidden object, such as a hidden luminous object. (See Creating hidden luminous objects on page 54.) Locked to lock the object. (See Locking objects on page 37.) Subtractive to use the object to cut through another object. (See Creating openings in objects on page 26.) 3 Click in the document window to locate the center of the box. Hold down the mouse button and drag to reposition the object.
Creating cones and columns
A column is an object that is the same diameter at all points between its top and bottom edge. A cone is an object that can have a larger diameter at its bottom than at its top. For example, you can use a column to hold up the roof of a building, and you can use a cone to represent the nose cone on an airplane. You can slant a cone or column at any angle from 0 to 90 degrees, relative to the point of view of visitors to your world.

Grouping objects

Grouping lets you control a set of objects as a single unit. When you manipulate a group, all of the objects are equally affected. For example, if you resize a group, all of the objects change in size. In addition, grouping lets you maintain the spatial relationships between objects. For example, if you rotate a group, all of the objects are rotated around the same axis.

To group objects:

1 Select the objects you want to group. Be sure you select the object and not the objects connectors. (See Selecting objects on page 30.) 2 Choose Object > Group.
If youre not sure if an object is part of a group, view the hierarchy in the Objects palette. (See Using the Objects palette on page 29.)

To ungroup objects:

Select the objects you want to ungroup, and choose Object > Ungroup.

To create a new group:

Choose Object > New Group. The new group appears in the Objects palette.
To add objects to an existing group:
1 Select the group to which you want to add objects. 2 Choose Object > Activate Group. 3 Create new objects as desired. The objects are added to the active group.
atmosphere.book Page 37 Wednesday, March 21, 2001 6:14 PM

ADOBE ATMOSPHERE 37

Locking objects
You can prevent accidental changes to objects or groups by locking them. You might want to lock nished objects in a complex wireframe that are near or above other unnished objects. After you lock an object or group, you cant select it with the select tools or make any direct changes to it in the wireframe views. You can, however, select Browser view and change the texture of a locked object or group. Although you cant select an entire locked object with the select tools, you can select the connectors for locked object and resize it. Or if you change other objects connected to a locked object or group, the locked object or group can change its size, shape, and location.
To lock an object or group:
1 Select a wireframe view: Top, Side, or Isometric. 2 Select the object or group you want to lock. (See Selecting objects on page 30.) 3 Do one of the following: In the Object Inspector palette, select Locked. In the Objects palette, click the button to the left of the object name or group name. When a group or object is locked, a lock icon ( ) appears. Locking a group locks all of the subgroups and objects within it.

To view or update the location of an objects surface texture le:
1 Select Browser view, and use the move tool (
) to navigate to the object you want to

work with.

2 Select the edit texture tool ( ).
3 Click the object or face whose surface texture you want to view or update. 4 In the Object Inspector palette, update the referenced le by entering a new path in the URL text box or by clicking Browse and selecting a new le. 5 If you dont want Atmosphere Builder to update the path to the texture le when you publish your world, select Absolute Path. An absolute path must be the URL of a texture le on a Web server.
Rendering surface textures and colors
Rendering is the process of translating 3D data into pixels on your computer screen. The texture options in the Tool Inspector palette let you control how surface textures and colors are rendered in Atmosphere Builder. The Use Textures option determines whether surface textures and colors are displayed in Browser view. (Hiding textures and colors can help you see how lighting contributes to the world.) The Smooth Textures option determines whether texture quality is enhanced during rendering. Enabling the Smooth Textures option enhances the appearance of textures and reduces blockiness; however, it also increases rendering time. Note: These options do not affect how a world appears when viewed in the Atmosphere Browserthey apply only to the current Atmosphere Builder session. Selecting these options can also slow down rendering in Atmosphere Builder.
atmosphere.book Page 52 Wednesday, March 21, 2001 6:14 PM
To hide textures and colors in a world:
1 Select Browser view, and select the move tool (
2 Deselect Use Textures in the Tool Inspector palette. Only the luminous surfaces in the
world are displayed with textures.
To enhance texture quality:
2 Select Smooth Textures in the Tool Inspector palette.
Deleting surface textures
If you want to change an objects surface texture, you can simply apply a new texture over the existing one. Atmosphere Builder keeps track of all the textures for an object, but only displays the top-most texture. If you delete the top-most texture, you expose the one beneath it.
To delete a surface texture:
1 Select Browser view, and use the move tool ( ) to navigate to the object you want to work with. 2 Select the delete texture tool ( ).

Using the Lighting Control palette
The Lighting Control palette contains options for lighting a world. It also displays the number of faces that remain to be processed during a lighting pass and the percentage of pixels left to light in the currently-processing face.
atmosphere.book Page 57 Wednesday, March 21, 2001 6:14 PM

ADOBE ATMOSPHERE 57

To display the Lighting Control palette:
Choose Window > Lighting Control.

Applying lighting

Each time you apply lighting, Atmosphere Builder recalculates how much light nonluminous surfaces receive. You can apply lighting to a face of an object, an object, or every surface in the world. In addition, you can stop the lighting process at any time. These controls allows you to ne-tune the lighting in a world with precision. For example, you can queue up ve lighting passes, and stop the lighting process when you are satised with the results.
To apply lighting to every surface in a world:
1 Select Browser view. 2 In the Lighting Control palette, click Add Lighting to Scene. 3 If desired, click Add Lighting to Scene multiple times to execute multiple lighting passes.
Atmosphere Builder creates a queue that lists each surface in a world, and adds additional lighting passes to the end of the queue. The Faces eld in the Lighting Control palette displays the number of faces that remain to be processed at any time. The Pixels eld in the Lighting Control palette displays the percentage of completed pixels in the currentlyprocessing face.
To apply lighting to an object:
) to navigate until you can see the object
you want to apply lighting to.
2 Select the light object tool ( 3 Click the object.
To apply lighting to a face:
1 Select Browser view, and use the move tool ( ) to navigate until you can see the face you want to apply lighting to. 2 Select the light face tool ( ).
atmosphere.book Page 58 Wednesday, March 21, 2001 6:14 PM

3 Click the face.

If you use the light object tool or the light face tool while a lighting pass is in process, the object or face is processed rst. This makes it possible apply lighting to key surfaces of a world at any point during a lighting pass.

About working with JavaScript
If you know how to write JavaScript, you can add effects to your world using the Atmosphere JavaScript API (Application Program Interface). These effects can be simple or complexranging from adding a sound effect to creating an interactive animation. The possibilities are limited only by your ability to implement your ideas in JavaScript. Keep in mind that this documentation doesnt explain how to write JavaScript codeyou can nd a wealth JavaScript resources on the Web and in print. This documentation does provide information about how to incorporate scripts into a world and gives you some ideas for what you can do with the Atmosphere JavaScript API. For more information, see the Atmosphere JavaScript API documentation. This documentation is installed with Atmosphere Builder and is accessible from the Atmosphere folder in the Windows Start menu.
Attaching a script to a world
You can attach a script to an object, a group of objects, or a whole world. If you attach a script to an object or group, you can use the keyword this to refer to the current object. Alternately, you can attach a script to the world and refer to objects by name. The world script is always run before any of the other scripts; therefore, you can use the world script to do initializations and provide methods that are required by other scripts.
To attach a script to an object or group:
1 Select a wireframe view: Top, Side, or Isometric. 2 Select the object or group to which you want to attach the script. 3 In the Object Inspector palette, enter the location of the JavaScript source le in the JavaScript URL text box.
To attach a script to a world:
In the World Settings palette, enter the location of the JavaScript source le in the JavaScript URL text box.
atmosphere.book Page 62 Wednesday, March 21, 2001 6:14 PM
The Atmosphere JavaScript API comprises a set of modules that cover a broad range of functionalityfrom adding buttons to the Atmosphere Browser to applying transformations to an object. The following topics describe some of the things you can do with the Atmosphere JavaScript API. Note: The Atmosphere JavaScript API is under continual development. For the most up-todate information, see Atmosphere JavaScript API documentation. This documentation is installed with Atmosphere Builder and is accessible from the Atmosphere folder in the Windows Start menu.

Adding sound

The Sound module provides methods and properties for implementing sound effects in a world. You can add both ambient and positional sounds to a world. An ambient sound is one that emanates from the entire world; while a positional sound is tied to a static or dynamic position in the world. For example, you can write a script that plays a creaking sound when a user navigates into a given position in the world. Atmosphere supports WAV format and MP3 format for sound effects. For example, the following code adds a sound and denes its parameters:

To change the position and orientation of an entry point, rst change your position and orientation in Browser view, and then click Move to Viewer Location in the Object Inspector palette.

Creating a portal

When you create a portal, you create a gateway for users to travel to another world. In order for the gateway to function, you must specify the URL of the world you want your portal to connect to. You can also specify the name of the entry point where you want users to enter the destination world. If you dont specify an entry point name, the portal connects to the default entry point in the destination world.
atmosphere.book Page 69 Wednesday, March 21, 2001 6:14 PM

ADOBE ATMOSPHERE 69

Creating portals is easy if you know the world URL and name of the entry point you want to connect to. But what if you dont know this information? Atmosphere Builder provides an easy way to deal with this situation. First, explore different worlds on the Web using Atmosphere Browser. When you nd a world you want to create a portal to, create a bookmark. Then, import the bookmarks into Atmosphere Builder. A tool for creating a portal to each bookmarked entry point appears in the Variable Tools palette.
To create a portal using the portal tool:
1 Select a wireframe view: Top, Side, or Isometric. 2 Select the portal tool ( ) in the Variable Tools palette.
3 In the Object Inspector palette, specify the entry point you want to link to in the Target World URL text box using the following format:
http://server/world/world.3da#entry_point_name
Important: Use a pound character (#) to separate the URL and the entry point name. The entry point name must correspond to the Entry Point Title option for the entry point in order for the gateway to function. If no entry point name is specied, the portal connects to a default entry point in the destination world.
4 Click in the document window to place the portal.
To create a portal by importing bookmarks:
1 Use Atmosphere Browser to explore different worlds on the Web. When you enter a world to which you want to add a portal, create a bookmark. A bookmark records the URL of the world and the name of the entry point you entered through. 2 In Atmosphere Builder, choose File > Import Bookmarks. A tool for creating a portal

 

Tags

DVP-S530D TX-32PS12F RA-840BX Deluxe AMP Asko T701 WV-CW964 OT-802 SLV-SE440K P-2000 4 1 DVD-LS80 RSH5sbbp WLI-CB-g54A Dynax 5D Accus ER8218C A Mole ADV-1000 Voice ECR 5700 LB 562 TC7102 WF203ANS Tomtom 920T NP-Q530-js01 Review Firefox F15 BL 5013 Spanish ML-2150 Outrun 2 Asko W660 GRC-151 HL-2170W Pentax MZ-L Revenge CA-520 1440T PAC160 Sport 10 Plus V4 5 System Scenic EB FAX-817 AV-29L6SU ZMC19MG 4351CT Security 4 GC2520 Coche T4X SGH-E420 Imovie 08 CCD-TRV21 Alertegps G100 VCL-DH2630 LAC7750R XG-55 T303C Catalogue 2007 42FD9954 Wisl 66 R-772 W710I Cateye V3 2200 08 DP450FR CMT-HX3 VR180 DAV-FXG9K DFX-5000 Wintv-HVR Thinkpad A22M Touch 556 TL-WN910N Lide 60 DBP-1610 Nikkor Xpoint SGH-Z500 Router Presario 2500 DMR-E55EBL GT-E1120 Ixus 400 Powerdirector 5NE VGC-VA170B CP200FR 01 2P XM-450G RS-50 VP-W61 Kh 1166 TL-SF1016 SCD-XE670 XRS R9G NBG-417N Ii 60 DHC-MD5 EC710 GEX-P700DAB

 

manuel d'instructions, Guide de l'utilisateur | Manual de instrucciones, Instrucciones de uso | Bedienungsanleitung, Bedienungsanleitung | Manual de Instruções, guia do usuário | инструкция | návod na použitie, Užívateľská príručka, návod k použití | bruksanvisningen | instrukcja, podręcznik użytkownika | kullanım kılavuzu, Kullanım | kézikönyv, használati útmutató | manuale di istruzioni, istruzioni d'uso | handleiding, gebruikershandleiding

 

Sitemap

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101