Reviews & Opinions
Independent and trusted. Read before buy Macromedia Director MX 2004 - Using Director!

Macromedia Director MX 2004 - Using Director

Manual

Preview of first few manual pages (at low quality). Check before download. Click to enlarge.
Manual - 1 page  Manual - 2 page  Manual - 3 page 

Download (English)
Macromedia Director MX 2004-using Director, size: 5.8 MB
Instruction: After click Download and complete offer, you will get access to list of direct links to websites where you can download this manual.

About

Macromedia Director MX 2004 - Using DirectorAdvergaming developer's guide: using Macromedia Flash MX 2004 and Director MX [Book]

By Rod Afshar, Duke Banerjee, Clifford Jones - Charles River Media (2004) - Paperback - 449 pages - ISBN 1584503165

Learn what Advergames are, how to use them, and how to create your own! Welcome to the world of Advergaming! Interactive games are one of the fastest growing forms of entertainment and theyre on track to exceed movie ticket sales. Using them as an advertising tool, however, is a relatively new idea that is catching on fast. Advergames are created not only to entertain, but to sell a product, brand, or company. More and more companies are using these free, brand-centric games to supplement, and e... Read more

Details
Advergaming Components: 11
PARTI The Tools: 21
Macromedia Flash MX 2004: 65
The Concepts: 91
Building an Advergame: 103

 

[ Report abuse or wrong photo | Share your Macromedia Director MX 2004 - Using Director photo ]

Video review

Typo (Interactive Macromedia Director made in 2004)

 

User reviews and opinions

<== Click here to post a new opinion, comment, review, etc.

Comments to date: 7. Page 1 of 1. Average Rating:
Sektion8 4:48pm on Saturday, October 23rd, 2010 
I love my lexus rx 300. I bought it at the auctions in Glasgow a few years ago the replace my freelander (which was agricultural next to the Lexus. Fast OR frugal--the choice is yours! With a 0 to 60 time around 7seconds it leaves most 4X4s for dead.
jalil 5:31am on Sunday, September 26th, 2010 
It handles great. In fact, the handling and traction allowed me to avoid a potential major multi-car accident Nothing bad about the product.
angelinvi 10:36am on Friday, September 10th, 2010 
Nice car, but definitely skip the navigation.  Smooth, quiet ride, surprisingly large interior, good acceleration and braking, nice sound system.
JonnyDe83 10:28pm on Tuesday, August 17th, 2010 
With an impending birth we needed to change our 2 seater sports car for something more practical and decided to go for an SUV style vehicle for the sp...
vbenner 10:00am on Monday, July 12th, 2010 
I have purchased 3 Lexus cars in the last 5 years. The last one being an RX400. My car died over night in the middle of snow. There were so few reviews about this Lexus RX400h car when I was looking to buy one I promised myself I would add one when I had sufficient experience...
yoramfr 1:28am on Sunday, July 4th, 2010 
It is a good buy without the Navigational sys...  I like the comfort, the ride, the practicality of all the mechanical interfaces. It handles great. In fact, the handling and traction allowed me to avoid a potential major multi-car accident Nothing bad about the product.
bymindx 7:33am on Thursday, April 29th, 2010 
I received one of the best birthday gifts from my wife, and I feel like paying her back soon. The gift was an all new Lexus RX 350.

Comments posted on www.ps2netdrivers.net are solely the views and opinions of the people posting them and do not necessarily reflect the views or opinions of us.

 

Documents

doc0

SM3117 Interactive Installation and Physical Computing Director Workshop I 26th January, 2005
Introducing Macromedia Director MX 2004
The Environment Key windows often used in Director MX 2004 : Stage, Cast, Score, Properties Inspector, Control panel and message window.

Control Panel

Property Inspector

Message

Menu Bar
Shortcut to bring up different windows
Vector Paint shape Text Shockwave 3D

Rewind Stop Play

Stage Cast
Property Library Inspector
Behaviour Script Message Inspector
Directors Terminology Movie Cast Member Score Frame Channel The primary Director file. It contains one or more Casts and a Score. Its the only Director file you need for most productions. Also called the movie file. The list of cast members used in a move. Also called the cast library. A single element, such as a bitmap, some text, a sound, a shape, a vector drawing, a Flash movie, or a piece of digital video. Also called a cast member. A chart showing which members appear on the Stage at certain times. An instant of time in Director. While you are working on a movie, the stage shows a single frame. While the movie is animating, the stage moves through frames to create the visual effect of animation. A numbered position in the Score. Every sprite occupies a channel over a series of frames. The score can have as many as 1,000 channels, as well as a few special channels at the top. The specific channel a sprite is in determines whether it gets down on top of or underneath another sprite. Also called a sprite channel. The description of which member is shown, where it is in the Score, where it appears on the Stage, and many other properties.

Sprite

Exploring Windows and Panels

The Cast Panel

Cast members-- The most basic elements of any Director movie. Almost any form of media can be represented in Director as a cast member. Each type of cast member can be viewed or edited in the Media Editor panel. There are two viewing modes : List and Thumbnail mode
click here to change view style

Cast Member Type

How you work with Cast member types vary greatly. Some can be created and edited in Director. Ohters need to be created in programs such as video or sound-editing tools and then imported.
Multiple / External Casts
Director allows you to break your members up into multiple cast libraires. The default Cast named internal. To create a new Cast, open the Cast panel and use the Choose Cast button menu at the upper left to choose the New Cast option. You can also choose File > New > Cast from the main menu bar. When you create a new cast, you have the choice of whether this new cast should be internal or external. An internal cast is stored in the same Director file as your default cast and the rest of the movies information. An external cast is stored in its own file with a.cst extension.
Tab to switch between Casts
Cast Member Name Cast Member Properties
Choose Cast / Create new Cast
Cast Member Number Icons representing different Member Type
The most versatile and most useful tool panel in Director. This panel contains information about the current sprite selected. So its appearance and function change constantly. It shows all the tab associated with the selected items. For instance, if you have a bitmap sprite selected, the Property Inspector will have Sprite, Behavior, Member, Bitmap, and Movie tabs.

Stage Properties

You can change the actual Stage size by choosing Modify > Movie > Properties and looking at the Movie tab of the Property Inspector.

The Stage

The Stage is the only window that the end user will actually see. It is where all the visual action of a movie takes place. The Stage has two main purposes: 1) to show you a preview of what the users will see. 2) to allow you to position sprites on the screen. You can change the actual Stage size by choosing Modify > Movie > Properties and looking at the Movie tab of the Property Inspector.

The Score

The score is the real heart and soul of a movie. As you can see below, it is a chart of the contents of the movie. Time, represented by frames, goes across the Score, whereas sprite channels and other elements are listed as rows in the chart.
marker behaviour inspector behaviours ink blend start / end frame hide / show effect channels markers menu
tempo palette transition sound frame script

effect channels

zoom menu show/ hide sprite channel name sprite
sprite channels channel number
The left side of the Score shows channel numbers. By default, the score has 150 sprite channels. You can change the number of channels in a movie through the movies Properties Inspector.

Effects channels

Tempo To specify the speed (fps) at which the movie moves through this frame. This setting persists until another frame contains a new setting to override it. You can also set the Tempo channel to pause for a certain number of seconds. You can use the palette channel of the Score to set which palette is used in which frame. Predefined visual transition that can be applied to a frame. The transition defines how the frame appears as the movie goes from the preceding frame to the current one. The two Sound channels enable you to defind sounds that automatically play when a frame is shown. You can use even more sound channel in Lingo. You can place Lingo / JavaScript members that are meant to control that specific frame, the sprites on it, and the entire Director environment, as long as the movie is passing through that frame. P.4
Palette Transition Sound Frame Script

The Message Panel

The Message window provides a way for you to test scripting commands and to monitor what is happening in your scripts while a movie plays.

script language chooser

input pane

output pane

The Message window has an Input pane and an Output pane. The Input pane is editable. The Output pane is read-only. The only way to display text in the Output pane is by calling the put() or trace() functions. You can test Lingo and JavaScript syntax statements to see how they work by entering them in the Message window and observing the results. When you enter a command in the Message window, Director executes the command immediately, regardless of whether a movie is playing. For example, if you type the following statement into the Message window: // JavaScript syntax trace(50+50); and press Enter, the result appears in the Output pane: // JavaScript syntax // 100
Working with Director member types

Using Text Members

Create Text
Director provides two ways to create text cast members: directly on the Stage or in the Text Editor window. To create text cast members directly on the Stage, use from the tool palette.
Note: The Text tool is available when the Tool palette is in Classic or Default view. When in Flashcomponent mode, the tool becomes a textInput Flash component.
To create text cast members in the Text window, open up the Text Editor by clicking the the menu bar.

icon from

You can set a variety of options to change the appearance of your text member. To change text member properties, use the Property Inspector. However, if you want to change the text properties (e.g. font, size, color etc.) of that text member, you need to use the Text Inspector instead. (or you can actually do that inside the Text Editor window)

Text Importing

Director allows you to import text of various format into the movie. To import an external text file, choose File > Import File format supported by Director : RTF, HTML, ASCII (often called Text Only), Lingo, or JavaScript syntax

Using Field Members

Once the only text option in Director, field members are still useful for a variety of tasks. For one, they take up much less space than text members. The difference is even more dramatic when you use anti-aliased text in the text member.
Note: The Field tool is only available when the Tool palette is in Classic view.
Field text is standard text controlled by your system software, the same as the text you see in dialog boxes and menu bars. Director does not anti-alias field text or support paragraph formatting and tabs for fields. As with regular text, script can control field text and specify whether field text is editable while a movie plays. Whereas regular text is best suited for large type that you want to look as good as possible, field text is an excellent choice for large blocks of smaller text in standard fonts (such as Times or Helvetica) that dont need to be anti-aliased.

Factor

Which to use Text Field Field Text Text Text Text Field Field Text Text

Konwing

when to use Text and when to use Fields
Must look smooth Must display quickly Must not add too much to the file size Must be capable of displaying indents Consistent line spacing Must be capable of displaying tables Must be capable of receiving imported RTF and HTML files Must be able to add borders and margins easily Must be able to add a text shadow easily Must be able to add hypertext links easily Must never change appearance from platform to platform

Using Bitmaps

Bitmaps are usually photographs, rendings, scanned image, or non-vector illustrations. You can created bitmaps in a variety of programs and then bring these images into Director by importing from a variety of standard formats. You can also create and edit bitmaps by using Directors Paint Editor.

Types of Bitmaps

Bit Depth
The biggest difference between types of bitmaps is that they can be of different bit depths. Bits refer to the amount of information stored for each pixel of a graphic. A 1-bit image has only one piece of information: on and off. An 8-bit image has eight pieces of information, which corresponds to 256 possible combinations. With todays computers, there is little need to use anything less than 32-bit graphics. Formats which are supported in Director: BMP, GIF, JPEG, LRG, Photoshop, MacPaint, PNG, PICT, Targa, TIFF After you import any of these file formats into Director as a bitmap, it no longer matters what the original format of the document was; it is now a bitmap cast mamber. You can edit bitmap images in Director with the Paint Editor. To fire up the Paint Editor, just double-click a bitmap cast member or using [Crtl + 5]

Photoshop filter

Director can borrow some Photoshop filters and use them on cast members or in the Paint Editor. You can do so by making an alias or shortcut to your Photoshop filters folder and placing it in the Director Xtras folder. You can also copy filters, or folders of filters, into the Xtras folder. The simplest way to use filters is to apply them to an entire single cast member. Select that cast member in the Cast and choose Xtra > Filter Bitmap. This bring up the filter Bitmap dialog box, which organises the filters into categories. To use a filter, select it and click the Filter button. If the filter has its own dialog box, as must do, you see that idalog box first and can then choose your options. The filter is then applied to the cast member.

Creating Vector Members

There are two types of vector member in Director. Vector Shape and Shape. Vector Shapes are created in the Vector Shape Window. (Choose Insert > Media Element > Vector Shape). Shapes are created directly on the Stage with the Tool palette. There are little differences between them except that Director does not ant-alias Shape members. So they dont appear as smooth on the Stage as vector shapes.
vector shape member shape member
There are various ways to handle sounds in Director : Importing Sound : Director stores all the sound data for an internal sound cast member in a movie or cast file and loads the sound completely into RAM before playing it. After an internal sound is loaded, it plays very quickly. This makes internal sound best for short sounds, such as beeps or clicks, that occur frequently in your movie. For the same reason, making a large sound file an internal sound is not a good choice because the sound might use too much memory. Using External Sounds : Director does not store sound data in a linked sound cast member. Instead, it keeps a reference to a sound files location and imports the sound data each time the sound begins playing. Because the sound is never entirely loaded into RAM, the movie uses memory more efficiently. Streaming Shockwave Audio : Director begins playing the sound while the rest of the sound continues to load from its source, whether on disk or over the Internet. This can dramatically improve the downloading performance of large sounds.

Using Sounds

Importing sounds
You can import sounds into Director with the same import function used for bitmaps and text. Choose File > Import > and select the sound file or files you want to import. After the sound is in the Cast, you can use the Property Inspector to view information about the sounds. Imported sounds will be placed in the sound channel. (In addition to the two sound channels in the Score, Director can use as many as six additional sound channels simultaneously. However, the additional channels are accessible only from Lingo or JavaScript syntax or from behaviors. ) There is only one available option in the Property Inspector -- Looping. If looping is turned on, Director plays this sound over and over as long as the sound is in one of the Sound channels in the Score. As soon as you jump to a frame that does not have this sound, it stops.

Import Dialog Box

Using External Sounds
Sounds tend to be large and add significantly to the file size of a Director movie. For this reason, you might want to keeping sounds as external files and creating a linked cast member that uses this external sound. Choose File > Import > to get to the Import dialog box, and then selecting Link to External File instead of Standard Import. Another method for using an external sound involves no cast member at all, but simply playing a sound file directly with a Lingo command, which will not be discussed here.
select Link to External File
Director imports AIFF and WAV sounds (both compressed and uncompressed), AU, Shockwave Audio, and MP3.
You can always check or update the file location from the Property Inspector.
Streaming Shockwave Audio
You can create a Shockwave Audio file from the Shockwave converter Xtra: select Xtras > Convert WAV to SWA, and select the WAV files to convert Director can stream the following sounds: QuickTime, Shockwave Audio, and MP3 sounds that are linked from a URL QuickTime, Shockwave Audio, MP3, AIFF, and WAV sounds that are linked to a local file
To stream a linked Shockwave Audio or MP3 sound:
1) Select Insert > Media Element > Shockwave Audio. This process creates a cast member that controls the streaming Shockwave Audio. 2) In the SWA Cast Member Properties dialog box that appears, click Browse and select a Shockwave Audio file on a local disk, or enter a URL in the Link Address text box.
3) Set the remaining cast member properties in the Property inspector, as described in the following list: To set the volume of the sound, use the Volume slider in the SWA tab in the Property inspector. To select the sound channel for the sound, select a number from the Channel pop-up menu in the SWA tab. To avoid potential conflicts, select Any, which causes the sound to play in the highest numbered available sound channel. To specify the size of the stream buffer, use the Preload option in the SWA tab. Director attempts to load enough sound data to play for the specified time in seconds. This prevents gaps in sounds that play over slow or interruption-prone Internet connections.

4) Drag the Shockwave Audio cast member to a sprite channel (not one of the sound channels) to create a sprite. Extend the sprite through all frames in which the sound should play, or use the tempo channel to make the movie wait for the end of the sound. You cant place streaming audio cast members in the sound channels. The sound streams from the source location when the movie plays.

Importing Digital Video

Media support for Windows : QuickTime video, RealMedia, (AVI, Mpeg-1, Mpeg-4 : through Window Media Xtra ) Medai suppor for Macintosh: QuickTime video, RealMedia When you import Windows Media, DVD content files, AVI, QuickTime, or RealMedia, the cast members you create always remain linked to the original external file, even if you select the Standard Import option. When you distribute a movie, you must always include all digital video files along with the movie. To import digital video: 1) Select File > Import. 2) Select QuickTime, AVI (Windows only), Windows Media (Windows only), or RealMedia from the Files of Type pop-up menu. 3) Select the digital video files to import. 4) Click Import. When you import an AVI file, you are prompted to select QuickTime or AVI as the import format. If you select QuickTime, Director imports the video as a QuickTime Asset Xtra, which provides additional playback options.
Video Window Whether a digital video is a cast member or a sprite on the Stage, you can preview it in its corresponding video window. There are different versions of the window for QuickTime, Windows Media, DVD, RealMedia, and AVI digital content. To open the Video Window, choose Window > QuickTime (or DVD, RealMedia, Windows Media, AVI Video)
Using DVD media content in Director
You can link DVD media content to a Director movie and use the DVD media editor to inspect that linked content. However, you can't actually make changes to DVD content within Director. Rather, you can change the attributes of the DVD media by using either the Property Inspector prior to playback or via Director's scripting capabilities while the movie's playing by polling events and modifying properties and methods that affect the linked DVD content. To link DVD media content to a movie by using the Insert menu: 1) Select Insert > Media Element > DVD. To link DVD media content to a movie by using the DVD Editor: 1) Select Window > DVD. (The DVD Editor appears.) 2) Enter a name for the DVD member in the Cast Member Name text box of the DVD Editor. Director creates a new DVD cast member in the first available Cast slot.

Synchronizing media

To pause the playhead until a specified cue point in a sound or digital video is reached, you can use the Wait for Cue Point option in the Tempo dialog box. You can also use this method to wait for the end of the sound or digital video, even if it has no cue points. Cue points can also be used to trigger events that scripts can interpret. Note: AVI and DVD media does not support Cue Point P.10

Simple Animation in Director
Something more about Sprite
A sprite is an object that controls when, where, and how cast members appear in a Macromedia Director MX 2004 movie. Multiple sprites can use the same cast member. You can also switch cast members assigned to a sprite as the movie plays. You use the Stage to control where a sprite appears, and you use the Score to control when it appears in your movie. Sprite properties include the sprites size and location, the cast member assigned to the sprite, the sprites name, and the frames in which the sprite occurs. Different properties can alter the appearance of a sprite. You can rotate, skew, flip, and change the color of sprites without affecting cast members. You can change sprite properties with the Property inspector or Lingo or JavaScript syntax. You can also give each sprite a unique name. You can assign a name by using the Property inspector, and then view the sprite by name in the Score and on the Stage. Assigning a name lets you refer to the sprite by that name in Lingo or JavaScript syntax and not just by the channel number that it occupies. You can move a sprite to a different channel and not worry about changing scripts. Editing scores and code scripts is much easier when you refer to a sprite by its name. In Lingo or JavaScript syntax, some properties are available only for certain types of sprites. Such properties typically are characteristics that are related to the specific sprite type. For example, Lingo or JavaScript syntax has several digital video properties that determine the contents of tracks in digital video sprites.
sprite channel number cast member type cast member cast a sprite sprite name

cast member

Tweening in Director
To tween the path of a sprite: 1. Place a sprite on the Stage where you want the path to start. If the sprite is already on the Stage, select it. This places the start frame of the sprite in the proper location. The start frame is also the first keyframe of the sprite. 2. If necessary, select View > Sprite Overlay > Show Paths. The Show Paths option is on by default. With this option turned on, Director displays the paths of moving sprites on the Stage. Keyframes appear as hollow circles. Small tick marks show the sprites position in tweened frames. 3. Insert keyframes in any additional frames where you want the sprites animation path to change. 4. Drag the red handle within the sprite to the place on the Stage where you want the sprites path to end. The red handle represents the sprites location in the end frame. For bitmaps, the red handle is usually in the center of the image. For vector shapes and other media types, the handle is often in the upper left corner.

5 Director displays the path the sprite follows. The tick marks along the path show the sprite location in each frame in between. 6. To make the sprites path curve between more points, hold down the Alt key (Windows) or Option key (Macintosh) and move the pointer on the Stage over a tick mark. When the pointer changes color, drag the tick mark to a new location.
7. To make the property changes defined by a keyframe occur at a different time, drag the keyframe in the Score to a new frame within the sprite. 8. To change the degree of curvature between keyframes, select Modify > Sprite > Tweening and adjust the Curvature slider. To make the sprite move in the same direction at the beginning and end, select Continuous at Endpoints in the Sprite Tweening dialog box. This creates a circular motion. To specify tweening properties for a sprite, you use the Sprite Tweening dialog box. Select a sprite, then select Modify > Sprite > Tweening.

Step Recording

To step-record animation: 1. Place sprites on the Stage where you want the animation to begin. 2. Select all the sprites you want to animate. 3. In the Score, click the frame where you want animation to begin. 4. Select Control > Step Recording. The step-recording indicator appears next to the channel numbers for the sprites being recorded, and the selection border widens. 5. Press 3 on the numeric keypad (make sure Number Lock is off) or click the Step Forward button in the Control panel. The movie advances to the next frame. If you reach the last frame of a sprite, Director extends the sprites being recorded into the new frame. 6. Drag the sprite to reposition it. You can also stretch the sprite, exchange cast members, or change any property. 7. Repeat steps 5 and 6 until you have completed the sequence you want to record.
step backward step forward

Real-Time Recording

You can set up a real-time recording session in the same way as a step-recording session. After the first frame of the sprite is selected, choose Control > Real-Time Recording from the menu. Click and drag the sprite. The movie starts going and the frame indicator on the Score moves with it. Drag the sprite around the Stage to change its position. When you are finished, you can go back and edit individual frames of animation.

Using Behavior Library

A behavior in Macromedia Director MX 2004 is prewritten Lingo or JavaScript syntax that you use to provide interactivity and add interesting effects to your movie. You drag a behavior from the Library palette and drop it on a sprite or frame to attach it. If the behavior includes parameters, a dialog box appears that lets you define those parameters. For example, most navigation behaviors let you specify a frame to jump to. You can attach the same behavior to as many sprites or frames as necessary and use different parameters for each instance of the behavior. Most behaviors respond to simple events such as a mouse click on a sprite or the entry of the playhead into a frame. When the event occurs, the behavior performs an action, such as jumping to a different frame or playing a sound.

To attach a behavior to a single sprite or frame using the Library palette:
1. Select Window > Library Palette. \ 2. Select a library from the Library pop-up menu in the upper left corner of the palette. 3. To view a brief description of included behaviors, move the pointer over a behavior icon. If the behavior includes a longer description, you can view it in the Behavior inspector or in Director Help. 4. To attach a behavior to a single sprite, drag a behavior from the Library palette to a sprite on the Stage or in the Score. 5. To attach a behavior to a frame in the behavior channel, drag a behavior from the Library palette to a frame in the behavior channel. 6. Enter parameters for the behavior in the Parameters dialog box.
To change parameters for a behavior attached to a sprite or frame:
Select the sprite or frame to which the behavior is attached. In the Behavior tab of the Property inspector, use the pop-up menus or text boxes to change any parameters. The Behavior tab has the same fields for the behavior as those in the Parameters dialog box.
Publishing Shockwave Movies
You can distribute movies as Shockwave content (with the DCR extension), projectors, Shockwave projectors, or protected movies (DXR extension). You should not distribute source movies (DIR extension) unless you want your users to be able to change the movie in the Director authoring environment. Shockwave content is a compressed version of a movies data and does not include a player. Shockwave content is created primarily to distribute over the Internet for playback in a web browser. A projector is a movie intended for play outside of a web browser. A projector can include a player (called the Standard player), Xtra extensions, multiple casts, and linked media in a single file. A projector can also include several different movie files. Configured in this way, a projector can be a completely stand-alone application. A Shockwave projector makes a much smaller projector. A Shockwave projector uses an installed Shockwave Player on the users system to play a movie instead of including the player code in the projector itself. Protected movies (.DXR extension) are uncompressed movies that users cant open for editing. These can be useful when you want to distribute uncompressed movies on a disk, but you dont want users to edit the source file. Protected movies may play faster than Shockwave content from a disk because they do not need to be decompressed.

Formats Tab

Use the Formats tab to select the movie format you want and determine the types of files you wish to publish. It includes support for creating cross-platform projectors.

Projector Tab

The Projector tab lets you set options that include how the projector movie appears on stage or in a browser, and what type of player it is shown on.

File Tab

The Files tab lets you set file options for projectors. For example, by default a projector consists of just the current movie, but you can add external casts to the movie using this tab. You can also exclude Xtra extensions from your projector.

Shockwave Tab

The Shockwave tab lets you set options that determine the Shockwave Player version, how images are compressed, how users interact with the movie once its published, and more.
To open the Publish setting dialogue box, choose File > Publish setting

HTML Tab

If users view your movie in browsers, chances are they will resize their browsers. How your movie behaves when the browser size changes depends on how you set HTML options in the Publish Settings dialog box.

Image Tab

You can specify the images that should appear if the user doesnt have Shockwave or the ActiveX control.

doc1

Applied Studies College Macromedia Director MX 2004
CSA 116: Digital Video and Audio
MACROMEDIA DIRECTOR MX 2004
Macromedia Director is a multimedia authoring program capable of creating Shockwave content for the web or self-contained executables for hard drive, DVD or CD-ROM.

THE DIRECTOR INTERFACE

Director's interface is designed around a movie / theatre metaphor. The media elements in a Director project are called the Cast members, they interact on a Stage, the Score keeps track of the media over time, and you, as the multimedia designer, become the director of a movie. A movie is the term used for a multimedia piece you create with Director. Like animated motion pictures, Director movies can contain animation, sound, special effects and even video. They also have an added dimension not capable in a motion picture, interactivity. Interactivity means that the movie responds to the choices you make. Director movies can be as simple as an animated logo, or as complex as an online chat room or game. Every movie has several unique qualities, including stage size, position, colour and much more. You specify the movie properties (as well as properties for other elements) in the Property Inspector. Director's User Interface (UI) is made up of a number of windows (also called panels). These windows can be grouped together to form tabbed panel groups. They can also be docked (linked) together or, in the case on some panel types, docked to the background (docking channels).
Prepared by: Mr. Basel Bani-Ismail

Page (1)

When creating and editing movies, you typically work with four key windows in Director's work area. These are: the Stage, the rectangular area where the movie plays; one or more Cast windows, where all the movie's media elements are stored; the Score, where the movie is assembled and the Property Inspector, which allows you to set the properties of various aspects of your movie. The Control Panel is another useful window, providing controls for playing movies. At the top of this page is the default workspace (panel set) layout. You can create and save your own panel set layout from Windows > Panel Sets > Save Panel Set Layout. You can also go back to the default layout at any time following the same process. In the default panel set layout (as in the screenshot), the Score and Cast are docked together. The Tool Palette is docked to the left docking channel. In the right docking channel, we see the Property Inspector. Docked underneath is the Library Palette in a tabbed panel group with the Behavior Inspector and Object Inspector. The Stage has a Control Toolbar built into the bottom of the window. This toolbar is a downsized version of the Control Panel. You can remove the Control Toolbar by choosing View > Control Toolbar (the Stage window must be active to allow you to do this). There are two types of windows in Director: document windows and tool windows. Document windows are used to create or edit content. Tool windows allow you to view or modify properties of this content. The Paint window is a document window, allowing you to create and edit images. The Property Inspector is a tool window that allows you to view properties of that image member (in the member tab). Some cast member properties displayed in the Property Inspector are not editable, like the creation date, while others can be modified. The Stage, Score and Cast are document windows. The Tool Palette, Control Panel are tool windows. Main Windows Summary The Score organises and controls a movies content over time in channels and frames (see below). It also controls special effects, such as transitions. The Cast window displays all the media that make up a movie, such as images, text, sounds, digital video. It can be viewed as series of icons (as shown in the screen shot above) or as a text list when in list view mode. The Stage is the 'screen' on which Director movies are projected. It is used to determine where all the visible media in a movie appear. The Property Inspector displays the properties of various elements of a movie, such as cast members, sprites, or the movie itself. The Control Panel provides a set of controls similar to those on a VCR to do things such as pause, play or rewind a movie.

Page (2)

Applied Studies College Macromedia Director MX 2004 The Score is made up of:
Channels - rows that contain effects (timing controls, transitions, sounds) and sprites (visual media). Sprites are instances of cast members on the Stage. The sprite channels represent how sprites are displayed and controlled over time. Sprite channels are numbered, allowing visible media to be layered on the Stage. Sprite channels can also be named (in MX 2004). The Score can be minimised or maximised by clicking the Hide/Show Effects Channels icon. Frames - numbered columns. A frame is a single step, or moment in time in the movie, like frames in a traditional film. The playback head shows which frame is currently displayed on the Stage. By clicking any frame in the Score, the playback head will move to that location in the movie.

Page (3)

TUTORIAL 1: THE BOUNCING BALL ANIMATING OBJECTS ALONG A PATH
We will start by creating a new movie and setting the Stage size. 1. Start a New Movie: File > New > Movie (Shortcut = Ctrl+N) 2. Choose Modify > Movie > Properties. The Movie tab of the Property Inspector appears. Change the Stage Size to 640 x 480. Note the other properties that can be changed. We are now going to create a ball, using a the Vector Shape editor. 3. Choose Window > Vector Shape (Shortcut = Ctrl+Shift+V) 4. Click the Filled ellipse button. 5. Draw an ellipse (circle) that fits into the Vector Shape window. Don't worry about being precise. We will be changing the size of it later.
6. Click on the Gradient fill button. This fills the ellipse with the default colours, which happen to be a light grey to red (unless someone has changed it on your computer). 7. To change the starting colour, click and hold on the colour box on the left side of the Gradient colour control. A palette of colours will appear. Choose a sky blue from the palette (just a colour that I like). You will notice the Fill colour chip changes colour to your selection. 8. Change the Gradient Type pull-down menu at the top of your window from Linear to Radial. 9. Change the Stroke Colour to white. Notice how the outline of the ellipse disappears. We are now going to change a few other properties of this ellipse. To allow us to compare these changes, we will make a copy of this cast member. 10. Close the Vector Shape window. 11. In the Cast Window, select the ellipse. Choose Edit > Duplicate (Shortcut = Ctrl+D). By doing this, we created a copy (or duplicate) of the cast member in the next available cast slot. We could have duplicated the vector cast member while it was open in the Vector Shape Editor too. Double click the new cast member to open it in the Vector Shape Editor.

Page (4)

12. Change the Cycles to 3 and the Spread to 200. (Again just some numbers I happen to like.) Click the Previous Cast button and compare the 2 ellipses. Experiment with different cycles and spreads to get an idea of what they mean. 13. Name the latest ellipse bouncing ball. This can either be done in the Vector Shape window or the Cast Member window. (See the screenshot above to identify where the name of the cast member appears.) Now we are going to animate the ball. 14. Drag bouncing ball from the cast member window to the Stage. You can drag and drop a cast member directly into the Score. This will centre it on the Stage.

15. Viewing the sprite on the stage, you will see a grey box underneath the ball (the sprite must be selected). This box is called the Sprite Overlay Info box.
You can change the transparency of the box by moving the black line, at the right end of the box, up or down. Even with a very high transparency, I still find this box gets in the way, so suggest we turn it off. Choose View > Sprite Overlay > Show Info. 16. Click on the Score to make it the active window. You will notice the ball sprite is extended over 30 frames. This is a default setting (which can be changed). Click on frame 30 of the sprite (its last frame) and drag it to frame 40. We are now going to resize the ellipse. 17. Click on the ball on the Stage to select it. Press Shift and, at the same time, click the bottom right corner handle of the sprite and drag up and to the left to make it smaller. Holding down Shift lets us resize the sprite in proportion to its original dimensions. Resize the sprite to approximately the size shown in diagram below (picture after step 20), and move it to the left side of the stage. 18. In the Score, click on frame 40 in channel 1 to select the last (end) frame of the sprite. Then click on the top the Stage to make it the active window. Now, holding down the Shift key, click and drag the ellipse to the right end of the Stage. Shift, in this case, restricts the movement to 90 degrees. You will notice a line being drawn on the Stage. This is the animation path. Rewind and play the movie to see what you created. 19. To curve the path, we are going to insert keyframes within the sprite. Keyframes are key points within a sprite that identify unique properties at that location. By having different properties at subsequent keyframes, we force Director to work out the in-between steps and thereby create animation. This process is called tweening.

Page (5)

Click on frame 10 of the sprite and choose Insert > Keyframe (Shortcut = Ctrl+Alt+K). Create keyframes at frames 20 and 30. 20. You will notice at each keyframe, a circle appears within the sprite in the Score as well as within the path shown on the Stage. You can select a keyframe by either clicking on the keyframe circle in the Score or double clicking the circle on the sprite path seen on the Stage. Select the keyframe at frame 10, and drag the circle up on the Stage. Do the same with keyframe 30, producing a path similar to that shown below. Rewind and play the movie.
Diagram showing animation path of ball, circles on path represent the keyframes. Now would be a great time to save your movie as tut1.dir.

Page (6)

You created an animation using Director's Tweening capability. Tweening is Director's term for 'inbetweening' and allows you to define the sprite properties at keyframes with Director working out the in-between steps for you. You can adjust the way Director tweens through the Sprite Tweening Dialog Box. 1. Select the animated sprite by clicking anywhere between 2 keyframes. 2. Choose Modify > Sprite > Tweening. This opens a dialogue box as shown below.
The Sprite Tweening dialog indicates which properties are tweened as well as how the properties are tweened. By default, the sprite settings allow for all properties to be tweened, including sprite size, location, rotation, among a few. We will be looking at some of these sprite properties in later tutorials. 3. Click and drag the curvature slider to the extreme left. You will notice the path diagram in the top left corner become more linear. 4. Drag the curvature slider to the extreme right and and observe how the path changes. 5. Click the Continuous at Endpoints checkbox and notice what happens. 6. Experiment with the various curvature options and play the movie to see how they affect the animated path of the ball.
Next we'll look at the Ease-In and Ease-Out properties 1. Delete the animating ball and recreate the ball animating along a straight line. 2. Select the sprite and open the Sprite Tweening dialog. 3. Drag the Ease-in slider to 50%, then rewind and play the movie.

Page (7)

The ball starts moving slowly and then speeds up. The animated path line seen on the Stage displays keyframes as circles and Director's in between steps over each frame as dots. Normally, the dots will be evenly spaced between keyframes. By choosing the Ease-in option, the dots are closer together at the start of the sprite and more spread out towards the end. 4. Experiment with various Ease-In and Ease-out settings. You can create animation using two other techniques - Step Recording and Real-Time Recording.
Step Recording is where you work out the new position/sprite property at each frame. By selecting the sprite and choosing Control > Step Recording, you can step forward frame by frame using the Control Panel. At each subsequent frame, a keyframe will automatically be created, allowing you to set new sprite properties. Real-time Recording allows you to record sprite movement when you drag it around the Stage. Director will record the path in real-time, creating keyframes at appropriate locations. You can access the Real-time recording capability through Control > Real-time Recording.

Page (8)

TUTORIAL 2: ANIMATING SPRITE SIZE THE SHRINKING BALL
1. Open tut1.dir. 2. In the Score, click on the end frame of the ball sprite and drag it to frame 60. Notice how all the keyframes spread out proportionally. Click on each keyframe and move the ball so the path looks something like the diagram below. 3. Change the size of each keyframe making the ball smaller as it moves along the path. Notice while you resize the balls, the path changes and you will need to edit the path again.

Diagram showing path of shrinking ball, with the large, starting ball slightly off screen. Rewind and play the movie. Now would be a great time to save your movie as tut2.dir.

Page (9)

TUTORIAL 3: MORE ANIMATED BALLS
Animating with the Property Inspector
The next series of tutorials animate other sprite properties. The diagram to the left shows the Property Inspector. The Property Inspector allows you to set properties for various elements of your movie, including sprites, cast members and even the movie itself. The sprite properties can also be viewed as an extension to the Score window, called the Sprite Toolbar. The Sprite Toolbar can be turned on and off by selecting View > Sprite Toolbar (while the Score is selected). In Director MX 2004, sprites can have unique names. Sprite channels can also have their own unique name, independent of the sprite name.
The Moody Ball - Animating sprite colour
1. Open tut1.dir. 2. Open the Property Inspector through Window > Property Inspector. The property tab for the movie will most likely be displayed. Click on Sprite to display the sprite tab as shown in the diagram above. 3. Click on the keyframes in the Score, and change the Foreground colour chip to different colours. I chose white, then pale pink, then a light bluish green, then yellow, and that worked well - feel free to experiment with any colours you like. Changing the foreground colour is Director's way of putting a coloured film over your sprite. The resulting colour is a mixture of the member's original colour and the 'film'. For this reason, light colours work better than dark colours for this effect. Rewind and play the movie.

Page (10)

The Disappearing Ball - Animating sprite transparency
Open tut1.dir. Click on the keyframes in the Score, and in the Property Inspector, change the Blend Transparency to 100, 75, 50, 25, 0 for the consecutive keyframes. The Blend property is shown to the right of the Ink property and is displayed as a %, with the default setting at 100%. Rewind and play the movie.
The Deforming Ball - Animating sprite shape
Open tut1.dir. Click on the keyframes in the Score, and change the Skew Angle to 0, 20, 40, 60 and 80 for the consecutive keyframes. Rewind and play the movie.

Page (11)

 

Technical specifications

Full description

Learn what Advergames are, how to use them, and how to create your own! Welcome to the world of Advergaming! Interactive games are one of the fastest growing forms of entertainment and theyre on track to exceed movie ticket sales. Using them as an advertising tool, however, is a relatively new idea that is catching on fast. Advergames are created not only to entertain, but to sell a product, brand, or company. More and more companies are using these free, brand-centric games to supplement, and even replace, traditional branding methods. If you are a Web designer, graphic designer, or game developer, youll want to learn more about Advergames. They're showing up everywhere, on the Web, cell phones, CD-ROMs, even embedded in email. The Advergaming Developer's Guide teaches designers and game developers the ins-and-outs of this innovative new form of advertising. It shows you how to create a variety of Advergames from the ground up, even if you have no prior game development experience. The book begins with a detailed overview of Advergaming, branding, gameplay, and the two main creation tools, Macromedia Flash MX 2004 and Director MX. From there youll learn how to conceptualize, develop, launch, and track the success of your Advergame. In the last part of the book, you'll create your own games, including a linking, matching, puzzle, memory, pinball, makeover, arcade, and whack-the-mole type game. And finally, youll learn about the business realities of Advergames through case studies with leading companies, including Blackdot, YaYa Media, Inc., and AGENCY.COM. This is the one resource you'll need to get started with Advergames, whether youre a Flash/Director developer already involved in advertising and game creation, a game developer looking to expand your development channels, or a Web designer looking for an innovative new tool.

 

Tags

MFC-7220 Mini 300 T8195B NP-N220P RCU600WMS RS21hdtts Marie-NO Tutorials AVH-P6850DVD Review CX-123II GSP-560 Electramac 235 Pentax MZ-M Forms SLD-200 ST500 Version 2 Laminator Taurus-1998 Siemens TK60 SGH-P900 Breil 1M52 147 Hifi 82287 CE7140 Equium A300 4641 Pyro DCB-P850R BC-CSQ3 CQ-C1100VN DPF-2030 RS20crsv5 MX850 SGH-C266 MZ-R501 Picturetel 210 GC4440 MP-370SD Dimage X60 37PFL5603H USG 2000 Revenge Modem 2100XL 50PC5D Lego 4497 NV-GS60EB RHT600R KV-27V36 850 ABS AW-E600 DTH8040 CT-740 ICF-C253 PLC-XU46 WTD1373K N1050V 6 2005 Mobile Disk HTR-5250 DB135 Systems F25261 Dvdr3430V 31 Channel S5500 EDC5340 Urc8206 SGH-X650 Toshiba D-R2 Fostex MR8 A8N5X ASF654 EL7055A Captiva 1200 UB AV-29L6SU Laserfax 925 PAC700T GC7320 MEX-DV2200 ES-WD741 PSC 1210 Astra 4450 MP-150 214SI Modem TCE7124 Proceed Pmdt LCX-15 MT IC-21A ACD-12 CD 950 PT2300 C T Invents PT-85 CPJ-7 Ls80 F1DB104P

 

manuel d'instructions, Guide de l'utilisateur | Manual de instrucciones, Instrucciones de uso | Bedienungsanleitung, Bedienungsanleitung | Manual de Instruções, guia do usuário | инструкция | návod na použitie, Užívateľská príručka, návod k použití | bruksanvisningen | instrukcja, podręcznik użytkownika | kullanım kılavuzu, Kullanım | kézikönyv, használati útmutató | manuale di istruzioni, istruzioni d'uso | handleiding, gebruikershandleiding

 

Sitemap

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101